В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Лиро1
Лиро1
26.03.2023 20:30 •  Информатика

Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10. (через паскаль)

Ответ:
garcinia
garcinia
24.05.2020 23:10

Паскаль.

 

 

program jjj;

var a: array [1..10] of integer; i,summa,proizv:integer;

begin

for i:=1 to 10 do begin

   Writeln('напишите элемент массива номер ',i); read(a[i]);

                        end;

For i:=1 to 10 do begin

                              if a[i] mod 2=0 then summa:=summa+a[i] else

                                if (a[i]<=10) and (a[i]>=1) then  proizv:=proizv*a[i];

                         end;

Writeln(summa,'   ',proizv); readln;

end.

 

Жирным - это то, что я добавил)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?