В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
наст55
наст55
22.06.2020 17:46 •  Информатика

Pascal. составьте программу замены местами в массиве b(n) первого положительного и минимального элементов. заранее

Ответ:
mvalinka
mvalinka
30.06.2020 11:28
Program gt;
var b:array[1..100]of integer;
r,i,n,q,min,t:integer;
begin
read(N);
q:=0;
for i:=1 to n do
begin
read(b[i]);
if(b[i]>0)then begin
q:=q+1;
if(q=1)then begin
r:=i;
t:=b[i];
end;
end;
end;
min:=b[1];
for i:=2 to n do
if(b[i]<min)then min:=b[i];
for i:=1 to n do
begin
if(b[i]=min)then b[i]:=t;
if(i=r)then b[i]:=min;
write(b[i],' ');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?