Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Red4521
10.04.2023 18:26 •
Информатика
Программа перевода из 10 сс в 16 сс на паскале. (как можно проще, используя функции, заранее .
Ответ:
rita1501
29.06.2020 12:49
Var
d, n: longint;
h: string;
begin
write('n? ');
readln(n);
repeat
d := n mod 16;
if d < 10 then
h := chr(ord('0') + d) + h
else
h := chr(ord('A') - 10 + d) + h;
n := n div 16;
until n = 0;
writeln(h, 'h');
end
0,0
(0 оценок)
Популярные вопросы: Информатика
fortunazanna
27.02.2020 06:04
Определи, может ли существовать такой IP-адрес: 101.167.209.135...
vvnels
23.09.2020 17:06
1 Что такое рабочее поле графического редактора Paint? 2 В каком случае можно не увидеть в рабочем поле Paint все изображение целиком? 3 Для чего используют меню инструментов?...
Elyzaveta2004
21.04.2023 07:48
Разрешающая экрана 512*1024 точек .объём графического изображения 640кб . найти количество цветов в палитре...
finn10
27.02.2021 03:46
Составить программу для вычисления группы элементов однородного массива c состоящего из 25 натуральных чисел, которые не меньше 10. организовать заполнения массива числами...
е7гроошишгини
19.05.2022 15:33
Решить по ин-фе про козу, волка и капусту, но без переправщика (рыбака), в таблице, желательно, толко в лодку вмещантся толко одно без рыбака и !...
funny43
06.05.2020 02:43
Программа на пайтоне. не могу найти у себя ошибку, из за которой происходит неверный вывод. (огэ 20.2): напишите программу, которая в последовательности натуральных...
ноолмллкшшп
13.06.2022 01:38
Как можно оценить средства икт в образовательной деятельности.2)как связаны средства икт...
Вика5552002
13.03.2021 20:06
Придумайте пример циклического алгоритма и запишите его в словесной форме....
geamget
25.09.2021 22:33
Вчём достоинства диалоговых программ...
bektemirova1
27.01.2020 20:18
Случилась такая беда, последний раз скачал я игру на пк, всё вроде было хорошо, через неделю произошел случай. я захотел порубиться в свой пк, но потом передумал, и отправил...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
d, n: longint;
h: string;
begin
write('n? ');
readln(n);
repeat
d := n mod 16;
if d < 10 then
h := chr(ord('0') + d) + h
else
h := chr(ord('A') - 10 + d) + h;
n := n div 16;
until n = 0;
writeln(h, 'h');
end