Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Artem517Art
22.02.2021 21:05 •
Информатика
Написать программу, которая проверяет, является ли введенная с клавиатуры строка двоичным числом. на pascal
Ответ:
lilav
01.10.2020 14:29
VAR
c: Char;
BEGIN
Assign(input, 'input.txt'); ReSet(input);
Read(c);
If (c <> '1') then begin Write('NO'); Exit; End;
While (not eoln(input)) do begin
Read(c);
If (c <> '0')and(c <> '1') then begin Write('NO'); Exit;
End;
END.
0,0
(0 оценок)
Популярные вопросы: Информатика
mi1980
30.05.2020 03:05
Определите значение переменной a после выполнения следующего фрагмента программы...
ellLMo
22.11.2021 11:45
Вкодировке кои-8 каждый символ кодируется 8 битами. определите информационный объем следующего сообщения: маил.ру – почтовый сервер”(с объяснением)...
Wkdj13737
17.12.2021 06:02
Антон сортирует по возрастанию список из пяти элементов: 15 9 4 7 1 ему разрешается поменять местами любые два соседних элемента. если левый был больше правого,...
Егор1123321
29.10.2020 05:53
Какое количество информации получит второй игрок при игре в крестики на поле 8*4 после первого хода первого игрока,играющего крестиком...
mygalmaksim
29.10.2020 05:53
На олимпиаде участники получают от 1 до 10 на каждом этаапе, которые затем кодируются специальным устройством минамально возможным количеством бит для каждого участника....
looooooooollll
16.05.2022 12:36
Паскаль авс.net . дано одномерный массив длиной n. сжать его , изъяв все отрицательные элементы....
oietillokhabiby
04.01.2023 22:30
Выполни действие и запиши верный ответ. 23mod5= 13div5=...
Dima2002dg
18.08.2022 20:27
Логическая функция задана выражением `F=barA*barB+C*A+bar(B+C)` Найдите значение функции при `A=1`, `B=0` и `C=0`....
Evilanda
26.10.2021 06:07
Напечатать все четырёхзначные натуральные числа, в записи которых есть одинаковые цифры. Составить программу....
chucklplplplpl
06.02.2023 22:50
В треугольнике ABC АВ = 2, АС = 3√2, ∠BAC = 45°. Найдите длину медианы AD....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
c: Char;
BEGIN
Assign(input, 'input.txt'); ReSet(input);
Read(c);
If (c <> '1') then begin Write('NO'); Exit; End;
While (not eoln(input)) do begin
Read(c);
If (c <> '0')and(c <> '1') then begin Write('NO'); Exit;
End;
END.