В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
матвей468
матвей468
09.10.2020 19:42 •  Информатика

Напишите программу на паскале.дан целочисленный квадратный массив 10x10.найти сумму максимальных элементов из каждой строки.предпологается, что в каждой строке такой элемент единственный

Ответ:

var
  a : array [1..10] of longint;
  i,j,max,ans : longint;
begin
  for i:=1 to 10 do
    begin
      max:=-maxlongint;
      for j:=1 to 10 do
        begin
          read(a[i]);
          if a[i]>max then max:=a[i];
        end;
      ans:=ans+max;
      writeln;
     end;
  writeln(ans);
end.

И этот массив не квадратный. Такие массивы называют двумерными массивами.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?