В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rita239
rita239
27.06.2021 16:43 •  Информатика

Написать программу для нахождения а) нод, б) нок двух натуральных чисел а, b.

Ответ:
vytriskoivan
vytriskoivan
28.06.2020 20:59
Program gt1;
var m,n,q,r,t:longint;
begin
read(m,n);
t:=m*n;
r:=1;
while r<>0 do
begin
q:=m div n;
r:=m mod n;
if (r<>0)then begin
m:=n;
n:=r;
end;
end;
t:=t div n;
write(n,' ',t);
end.
t-НОК
n-получившиеся НОД
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?