В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ivahinzeha475
ivahinzeha475
15.11.2020 17:44 •  Информатика

Кто может разобрать ? ? 70 ) program n1; var i,n,sum: integer; begin readln(n); sum: =0; for i: =1 to n do sum: =sum+2*i; writeln(sum); end. написать программу, которая вычисляет сумму первых n целых положительных четных чисел. количество суммируемых чисел должно вводится во время работы программы.

Ответ:
Olga2442
Olga2442
24.05.2020 22:39

Program n1;  

//Название программы

var i,n,sum: integer;  

//Объявление переменных

begin  

//Начало

readln(n);  

//Ввод n (количество чисел) и и переход на следущую строку

sum:=0;  

//Присваивание переменной sum знаяения 0 (изначально сумма равна 0)

for i:=1 to n do sum:=sum+2*i;  

//В цикле от 1 до n к переменной  

//sum прибавляем 2*i, т.е. 1*2+2*2+3*2+..n*2=2+4+6+..+2n;

writeln(sum);

//Ввод sum (cумма первых n целых положительных четных чисел)  

//и и переход на следущую строку

end.

//Конец

0,0(0 оценок)
Ответ:
polinamanush155
polinamanush155
24.05.2020 22:39

Program n1;// программа на паскале n1

var i,n,sum: integer;// объявление целых переменных i,n и sum

begin //начало программы

readln(n); //ввод n

sum:=0;/ /присвоение переменной sum нач. значения 0

for i:=1 to n do sum:=sum+2*i;// цикл для вычисления суммы

writeln(sum);// печать суммы

end. //конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?