В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
asti2000
asti2000
26.01.2021 00:43 •  Информатика

1. написать программу для решения : точки на плоскости заданы своими координатами. определить какая из них находится ближе к началу координат.

Ответ:
sofiyaserysheva
sofiyaserysheva
01.10.2020 14:11
Uses crt;
var n,minind,i:integer;
min,x,y:real;
begin
writeln('Введите количество точек: ');
read(n);
writeln('Вводите по очереди координаты x и y точек.');
read(x,y);
min:=sqr(x)+sqr(y);
minind:=1;
for i:=2 to n do
begin
read(x,y);
if sqr(x)+sqr(y)<min then
begin
min:=sqr(x)+sqr(y);
minind:=i;
end;
end;
writeln('Точка под номером ',minind,'.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?