В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KosherDan
KosherDan
05.05.2023 17:59 •  Информатика

Написать программу, которая сортирует массив по убыванию и ищет в нем элемент, равный x (это число вводится с клавиатуры). использовать двоичный поиск.

Ответ:
maevava
maevava
28.06.2020 12:19
uses crt;
var a, b, c, n, i, j :integer;   
s :array [1..10000] of integer;
begin
   clrscr;
   writeln ('Vvedite razmer masiva');
   read (n);
   writeln  ('Vvedite chislo X');
   read (a);
   for i:=1 to n do 
   begin 
      writeln ('Vvedit s[', i, '] element'); 
      read (s[i]); 
   end;
   for i:=1 to n do 
      for j:=1 to n-1 do 
         if s[j]<s[j+1] then   
         begin   
            b:=s[j];   
            s[j]:=s[j+1];   
            s[j+1]:=b;   
         end;
   for i:=1 to n do 
   begin 
      write (s[i], ' '); 
      if s[i]=a then inc (c); 
   end;
writeln;
if c>0 then writeln ('3adanoe chislo prisytstvyet') else writeln('3adanoe chislo otsytstvyet');
end.

P.S. Надеюсь на благодарность и лучший ответ.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?