В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
BloodRainbow
BloodRainbow
21.03.2023 09:55 •  Информатика

1)написать программу, вычисляющую сумму и среднее положительных чисел, которые вводятся с клавиатуры.вид экрана: введите числа. для завершения последовательности нажмите ноль.45 23 15 0 введено чисел: 3 сумма чисел: 83 среднее арифметическое: 27.67 2)аписать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положи¬тельных чисел (длина последовательности не ограничена) . (цикл whil или repeat) определение максимального числа последовательности положительных чисел. вводите после стрелки числа. для завершения ввода введите ноль. -> 56 -> 75 -> 43 -> о максимальное число: 75.

Ответ:
ttttt18
ttttt18
28.06.2020 11:44
Uses crt;
var A, B:real;
begin
writeln('45, 23, 15'); 
writeln('Сумма чисел:3');
A:=45+23+15; B:=45+23+15/3;
writeln('Сумма чисел=',A);  write('Среднее арифметическое=',B);
end.
0,0(0 оценок)
Ответ:
37Zorky
37Zorky
28.06.2020 11:44
Uses crt;
var a,b,c,k:integer;
begin
a:=0; b:=0;     k:=1;
repeatread(c);
k:=c; a:=a+c; inc(b);

until k=0;
write(a,'   ',a/(b-1));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?