В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mantsigina
mantsigina
08.03.2021 23:44 •  Информатика

ABCPascal Составить программу, которая каждую встреченную в заданном предложении букву «р» заменяла бы сочетанием букв «ля».

Ответ:
Ka090907
Ka090907
13.01.2023 11:46

Відповідь:

program ReplaceRWithLya;

var

 inputString: string;

 outputString: string;

 i: integer;

begin

 inputString := 'Это предложение содержит несколько букв р.';

 outputString := '';

 for i := 1 to length(inputString) do

 begin

   if inputString[i] = 'р' then

     outputString := outputString + 'ля'

   else

     outputString := outputString + inputString[i];

 end;

 writeln(outputString);

end.

Пояснення:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?