В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
arlanout
arlanout
03.10.2020 15:42 •  Информатика

Ваша задача — написать программу, которая перемножает все цифры, введенного пользователем целого числа, пока оно не станет меньше либо равной 9. Число вводит пользователь с клавиатуры, и оно всегда должно быть больше нуля. Примеры:

999 -> 2 # 999 -> 9 * 9 * 9 = 729 -> 7 * 2 * 9 = 126 -> 1 * 2 * 6 = 12 -> 1 * 2 = 2

1000 -> 0

423 -> 8

1 -> 1
Надо решить без использования функций

Ответ:
GevorgStepanyan
GevorgStepanyan
08.08.2022 22:53

print("Введите целое число")

n = int(input());

i = 0

multiple = 1

string = str(n)

do = len(string)

while i < do:

   multiple = multiple * (n % 10)

   n = int(((n - n % 10) / 10))

   i += 1

   if (i == do):

       if (multiple > 9):

           n = multiple

           multiple = 1

           i = 0

           string = str(n)

           do = len(string)

       else:

           break

print("результат: ",multiple)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?