В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dima121007
Dima121007
23.07.2020 19:09 •  Информатика

1)Напишите программу которая запрашивает с консоли два целых числа (int n и int m) и выводит на экран все НЕЧЕТНЫЕ числа от n до m. 2)Напишите программу которая запрашивает с консоли два целых числа (int n и int m) и выводит на экран все числа от n до m которые делятся на 3 без остатка.
с++

Ответ:
INNADANILOVA
INNADANILOVA
28.07.2022 06:00

#include "iostream"

using namespace std;

int main() {

int n, m;

cout << "Task 1" << endl;

cout << "n = ";

cin >> n;

cout << "m = ";

cin >> m;

cout << "" << endl;

if (m%2 != 0) {cout << "m = " << m << ", ";}

if (n % 2 != 0) { cout << "n = " << n << endl; }

else if (n % 2 != 0 and m % 2 != 0) {cout << "n = " << n << endl;cout << "m = " << m << endl;}

else if (n % 2 == 0 and m % 2 == 0) {cout << "Nothing" << endl;}

cout << "Task 2" << endl;

cout << "n = ";

cin >> n;

cout << "m = ";

cin >> m;

cout << "" << endl;

if (m % 3 == 0) { cout << "m = " << m << ", "; }

if (n % 3 == 0) { cout << "n = " << n << endl; }

else if (n % 3 == 0 and m % 3 == 0) { cout << "n = " << n << endl; cout << "m = " << m << endl; }

else if (n % 3 != 0 and m % 3 != 0) { cout << "Nothing" << endl; }

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?