В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
promes2710
promes2710
04.11.2020 18:04 •  Информатика

Напишите программу, которая запрашивает у пользователя два целых числа a и b. С цикла for, посчитайте сумму всех чисел в диапазоне от числа a до числа b включительно, стоящие через одно. И выведите их среднее арифметическое. В задании не используйте условный оператор if, просто правильно пропишите range()

Например:

Входные данные:

-3

5

Выходные данные:

1.0

Ответ:
жигер21
жигер21
22.07.2022 17:49

a = []

n = int(input("Начало: "))

x = int(input("Конец: "))

for i in range(n,x+1):

   a.append(i)

print((sum(a))/len(a))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?