В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kitiry
kitiry
06.07.2022 13:45 •  Информатика

ОЧЕНЬ НАДО Робинзон прожил на острове f дней. Написать программу, которая определяет сколько это лет недель и дней.

Ответ:
ress123
ress123
27.04.2022 14:10

Программа:
Pascal:

var

 f, years, weeks, days: integer;

begin

 readln(f);

 years := f div 365;

 weeks := (f - years * 365) div 7;

 days := f - years * 365 - weeks * 7;

 writeln(f, ' дней - это ', years, ' лет, ', weeks, ' недель, ', days, ' дней.');

end.

Объяснение:

В начале регистрируются переменные f, years, weeks, days. Далее - вводится число f (дней). Число полных лет - результат целочисленного деления f на 365. Число полных недель - результат целочисленного деления оставшегося количества дней на 7. Число дней - оставшиеся количество дней после определения years и weeks. В конце - вывод этих значений.

Результат:

1000

1000 дней - это 2 лет, 38 недель, 4 дней.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?