В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
shakutis
shakutis
14.08.2021 06:19 •  Информатика

Напишите программу которая переводит число из 2-9 системы счисления в 10 на паскале


Напишите программу которая переводит число из 2-9 системы счисления в 10 на паскале

Ответ:
891447819danilDanil
891447819danilDanil
22.03.2022 13:40

Program From2To10;

var

n2: Longint;

n10, m, i: Integer;

begin

Write('n2 = ');

ReadLn(n2);

n10 := 0;

m := 1;

while n2 <> 0 do

begin

i := n2 mod 10;

n10 := n10 + i * m;

m := m * 2;

n2 := n2 div 10;

end;

WriteLn('n10 = ', n10);

end.

n2 - исходное число в двоичной записи

n10 - число в десятичной записи

m - 2 в степени номер разряда цифры

i - очередная цифра

Объяснение:

Вроде так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?