В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
thewitefox
thewitefox
14.05.2022 01:03 •  Информатика

Python У Саши на компьютере есть папка, где он хранит все свои фото для будущих публикаций. У каждого фото в этой папке есть особое название - семизначный номер.

В этом номере каждая цифра обозначает актуальность фото для определенной аудитории. Сейчас Саша хочет разделить семизначное число на цифры и выписать их в столбик с текстовыми пометками "популярно" (если число больше или равно 7) или "мимо" (если число меньше 7).

Формат входных данных
Семизначное целое положительное число N.

Формат выходных данных
Все цифры числа, начиная с единиц, каждое в отдельной строке. Рядом с цифрой слово "популярно" или "мимо" (в зависимости от цифры).

Ответ:
марья49
марья49
21.03.2022 12:40

n = int(input())

while n:

   a = n % 10

   s = 'популярно' if a >= 7 else 'мимо'

   print(a, s)

   n //= 10

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?