Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
oleg02122001
19.09.2020 17:33 •
Информатика
Написать программу нахождения наибольшего общего делителя (нод) двух натуральных чисел.а)использовать оператор repeatб) использовать оператор while
Ответ:
rystamgfţ
27.06.2020 12:55
var a,b: integer;
function NOD(x,y: integer): integer;
begin
if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
end;
begin
readln(a,b);
writeln( 'НОД = ', NOD(a,b) );
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
1505Анютка1505
03.12.2022 22:10
1. напишите программу, которая в последовательности натуральных чисел определяет количество всех нечётных чисел, кратных 7. программа получает на вход натуральные...
Марина8908
16.03.2020 18:16
1) Задача №112294. Три минимума Напишите программу, которая находит в массиве три минимальных элемента, то есть три первых элемента массива после сортировки по возрастанию....
benblast
08.02.2022 21:56
Внимание! Перед вами код, который писал юный программист, и он допустил одну маленькую ошибку. Давайте вместе с преподавателем попробуем ее исправить. Как вы уже догадались,...
VeronaKotik
27.10.2021 06:22
Ход выполнения программы может быть линейным, то есть таким, когда выражения выполняются друг за другом, начиная с первого и заканчивая последним. Ни одна строка кода...
daniil8092228
16.08.2020 02:35
Дано: for i:= 1 to 19 do При последнем выполнении тела цикла i= ....
артем1ппн
04.07.2021 04:54
40 ! в чем заключаются достоинства/недостатки фактологического подхода к представлению об информации?...
slavachekunov
03.04.2022 03:35
Решить. на совещании присутствовали 12 работников компьютерного отдела: программисты, системные администраторы и менеджеры. среди них 4 системных администратора. сообщение...
1939345
17.05.2021 15:10
Расcказ как я был в дилфинариуме по...
MartinaStoessel2
17.05.2021 15:10
Составить рассказы о природных зонах (смешанные леса; степи)...
trololoshka25
17.05.2021 15:10
Как пишется слово ливый и 100 осень...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
function NOD(x,y: integer): integer;
begin
if x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
end;
begin
readln(a,b);
writeln( 'НОД = ', NOD(a,b) );
end.