Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
sergeu3522p09njx
15.09.2021 07:21 •
Информатика
нужно написать программу для решения следующей : вычислить количество элементов числовой последовательности а, удовлетворяющих условию -0,2< =sin ai < =0,5, i=1, n
Ответ:
sabah2017
27.06.2020 11:35
#include <iostream>
using namespace std;
void main()
{int n,k=0;float b=0;
cout<<"Vvedite n=";cin>> n;
cout<<endl; float* f = new float [n];
for(int i=1;i<=n;i++)
{
cout<<"A["<<i<<"] = ";cin>>f[i];
}
for(int i=1;i<=n;i++) {
b=f[i];
if(-0.2<=sin(b)<=0.5)
{
k++; cout<<"Znachenie sinysa = "<<i<<"el-ta "<<sin(f[i])<<endl;
}
b=0;
}
cout<<" Kol-vo ravno="<<k<<endl;
system("pause");
}
0,0
(0 оценок)
Популярные вопросы: Информатика
2261747
16.05.2022 20:26
Ограничение времени 2 секунды ограничение памяти 64mb ввод стандартный ввод или input.txt вывод стандартный вывод или output.txt назовём скобочную последовательность, состоящую...
Діанагрeк
08.08.2021 16:20
сформировать и вывести на экран массив элементы которого заданы датчиком случайных чисел на интервале от -19 до 26 найти произведение элементов с нечетными номерами...
yura204080
18.02.2020 02:26
Автомат обрабатывает натуральное число N по следующему алгоритму: 1. Строится двоичная запись числа N без ведущих нулей. 2. Если в полученной записи единиц больше, чем нулей,...
retrovaweforyou
11.06.2022 10:09
При равномерном кодировании символов кодовое слово занимает 4 бит. Сколько различных символов можно закодировать с такого кода?...
senan53
22.08.2022 06:08
Создать список из 10 случайных элементов (от -10 до 10). Найти разность между наибольшим и наименьшим элементами списка У python все написать...
hamsterizumkin
26.06.2021 05:03
1. Запишите число 76 в восьмеричной системе счисления. 2. Запишите число 1358 в десятичной системе счисления. 3. Запишите число 2618 в двоичной системе счисления. 4. Запишите...
katia6173
16.06.2021 04:25
Упрости и запиши верный ответ. M&B∨M&B¯¯¯...
znanija114
28.03.2021 20:04
Режимами называются отображения и работы над презентацией. Не существует такого режима... 1.Обычный 2.сортировщик слайдов 3.показ слайдов 4. Цветовая схема...
ryvdgruhcdgghhhFrubf
27.02.2023 22:43
Какая кнопка окна программы Power Point предназначена непосредственно для вставки текстового блока на слайд?...
vinogradovanactaxa
26.11.2022 00:52
по питону мой код:a, b, c = int(input()), int(input()), int(input())if a != b: print(b)elif b = c: print(c)else: if c == a: print(a)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
void main()
{int n,k=0;float b=0;
cout<<"Vvedite n=";cin>> n;
cout<<endl; float* f = new float [n];
for(int i=1;i<=n;i++)
{
cout<<"A["<<i<<"] = ";cin>>f[i];
}
for(int i=1;i<=n;i++) {
b=f[i];
if(-0.2<=sin(b)<=0.5)
{
k++; cout<<"Znachenie sinysa = "<<i<<"el-ta "<<sin(f[i])<<endl;
}
b=0;
}
cout<<" Kol-vo ravno="<<k<<endl;
system("pause");
}