В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
caros14
caros14
21.08.2022 11:40 •  Информатика

Написать программу нахождения сопротивления цепи из n (r1,r2, ..rn) соединённых последовательно (pascalabc)

Ответ:
imuraveva
imuraveva
27.06.2020 11:19
При последовательном соединении сопротивление цепи будет равно сумме сопротивлений.
uses crt;
var r:array [1..10000] of integer;
    n,x,RSum:integer;
begin
     RSum:=0;
     write('N='); readln(N);
     for x:=1 to N do
     begin
          write('R',x,'=');
          readln(r[x]);
          RSum:=RSum+r[x];
     end;
     writeln('R=',RSum);
end.     
0,0(0 оценок)
Ответ:
Селена24на7
Селена24на7
27.06.2020 11:19
Var a, n, i, s : integer;
begin
read (n);
for i:=1 to n do 
 begin
 read (a);
 s:=s+a;
 end;
write (s);
end.

В последовательном соединении R_c=R_1+R_2+R_3+...+R_n

P.S. Надеюсь на благодарность и лучший ответ.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?