В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
polly133
polly133
25.01.2023 03:45 •  Информатика

Напишите программу, которая заполняет список из 10 элементов случайными числами на отрезке [-50; 50]. Найдите сумму всех элементов, оканчивающихся на 2

Ответ:
Jastick
Jastick
04.03.2022 06:00

znanija

Поиск...

Избавься от ограничений

ПОПРОБУЙ ЗНАНИЯ ПЛЮС СЕГОДНЯ

User avatar

Nastyukha0

10.02.2015

Информатика

5 - 9 классы

ответ дан • проверенный экспертом

заполнить массив состоящий из 10 элементов случайными целыми числами из промежутка [-50;50]. Выведите на экран и вычислите сумму всех отрицательных элементов. Как в программе паскаль. Заранее огромное с:

1

СМОТРЕТЬ ОТВЕТ

Что означает фраза "КАК в программе паскаль" ?:

И потом, "Выведите на экран и вычислите сумму" - это не по-русски, потому что сначала надо вычислить, а затем вывести.

Войди чтобы добавить комментарий

Реклама

ответ, проверенный экспертом

5,0/5

3

Участник Знаний

const

n = 10;

var

x: array[1..n] of integer;

i, s: integer;

begin

Randomize;

Writeln('Элементы массива');

s := 0;

for i := 1 to n do

begin

x[i] := Random(101) - 50;

Write(x[i]:4);

if x[i] < 0 then s := s + x[i]

end;

Writeln;

Writeln('Сумма отрицательных элементов равна ', s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?