В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Maksim3131
Maksim3131
18.10.2020 19:52 •  Информатика

Составить программу на языке Паскаль для решения следующей задачи: Дан одномерный массив. В массиве хранятся оценки по информатике учеников 9 класса. Заполнить массив случайными числами, лежащими в диапазоне от 2 до 5 включительно. Вычислите среднюю оценку в классе по информатике. Входные данные для размерности массива задайте самостоятельно.

На проверку нужно прислать текст кода программы, результат работы кода в виде скриншота окна программы с отображением кода и полученного результата. Программная реализация обязательна!

Ответ:
влад2220
влад2220
26.02.2022 17:30

Программа:

Pascal:

var

 arr: array of integer;

 n, i, sum: integer;

begin

 write('Количество учеников: '); readln(n);

 SetLength(arr, n);

 

 for i := 0 to n - 1 do begin

   arr[i] := random(2, 5);

   sum += arr[i];

 end;

 writeln('Оценки учеников в классе: ', arr);

 writeln('Средняя оценка: ', sum/n);

end.

Для начала выделяем память массиву целых чисел, после - регистрируем переменные, которые будем использовать далее. Запрашиваем кол-во учеников (это и будет размерностью массива), устанавливаем длину массива - введённое число n. Циклом проходима по элементам массива, устанавливаем рандомное значение от 2 до 5 и суммируем элементы. В конце выводим сам массив и высчитываем среднюю оценку как среднее арифметическое чисел.


Составить программу на языке Паскаль для решения следующей задачи: Дан одномерный массив. В массиве
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?