В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
canay2211canay
canay2211canay
18.02.2023 10:05 •  Информатика

Составить программу, вычисляющую количество элементов двумерного массива, размерности 3 на 4, больших заданного числа.. паскаль

Ответ:
KaKTyZzZz
KaKTyZzZz
26.02.2022 11:20

Программа:

Pascal:

var

 arr: array[1..3, 1..4] of integer;

 i, j, n, count: integer;

begin

 write('Введите число: '); readln(n);  // ввод числа n

 for i := 1 to 3 do

   for j := 1 to 4 do begin

     arr[i, j] := random(100);  // заполнение массива случайными числами от 0 до 100

     if arr[i, j] > n then  // если число больше заданного числа, то...

       count += 1;  // увеличиваем значение переменной count на 1

   end;

 writeln('Массив: ', arr);  // вывод массива

 writeln('Чисел, больше ', n, ': ', count);  // вывод кол-ва элементов, больше n.

end.

Чтобы заполнить массив, для начала нужно выделить ему память. После этого запрашивает значение "заданного числа" n. После выделения памяти и запроса числа нужно в двойном цикле обойти все ячейки массива (i - номер строки, j - номер столбца). После начала цикла сначала заполняем массив случайными числами (от 0 до 100), а после находим количество элементов, больше заданного числа. В конце выводим сам массив и кол-во элементов, больше заданного числа.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?