В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
niqwe
niqwe
15.07.2020 11:17 •  Информатика

Напишите программу в паскаль
Надо выполнить а)- в)


Напишите программу в паскаль  Надо выполнить а)- в)

Ответ:
Петуч
Петуч
23.02.2022 20:20

a)

var

 a: array [1..20] of integer;

 i, count: integer;

begin

count:=0;

 for i := 1 to 20 do

 begin

   readln(a[i]);

   if a[i] >= 0 then

     count += 1;

 end;

 writeln(count)

end.

в)

var  a: array [1..20] of integer;

 i, countplus, countminus: integer;

begin

 countplus := 0;

 countminus := 0;

 for i := 1 to 20 do

 begin

   readln(a[i]);

   if a[i] > 0 then

     countplus += 1;

   if a[i] < 0 then

     countminus += 1;

 end;

 writeln(countplus, ' ', countminus)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?