В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MrWolf1244
MrWolf1244
28.01.2020 06:25 •  Информатика

Дан массив из n элементов. составить программу , сортирующую по возрастанию все числа с нечётными индексами в массиве.

Ответ:
vadimnigamaev
vadimnigamaev
01.10.2020 13:59
var
  a: array [1..100] of integer;
  i,j,n,k: integer;

begin
  readln(n);
  for i:= 1 to n do readln(a[i]);
  for i:= 1 to n do if Odd(i) then
    for j:= 1 to n-i do if Odd(j) then
      if a[j]>a[j+2] then begin
        k:= a[j];
        a[j]:= a[j+2];
        a[j+2]:= k
      end;
  for i:= 1 to n do write(a[i],' ')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?