В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
senan53
senan53
22.04.2023 20:52 •  Информатика

30 ! составьте программу ,которая формирует массив ,содержащий 12 случайных вещественных чисел ,принадлежащих промежутку от [-10; 30] , и подсчитывает произведение всех отрицательных чисел. вывод в столбец с тремя десятичными знаками.

Ответ:
ВераПончик
ВераПончик
27.06.2020 01:52
var
a:array[1..12] of real;
i:integer;
pr:real;
begin
randomize;

pr:=1;for i:=1 to 12 do begin
  a[i]:=random(41)*0.9-10;
  if (a[i] < 0) then
    pr:=pr*a[i]; 
end;
writeln(pr:5:3)
end.
0,0(0 оценок)
Ответ:
jora2003123
jora2003123
27.06.2020 01:52
Uses crt;
var a:array[1..12] of real;
    x:integer;
    p:real;
begin
     randomize;
     p:=1;
     for x:=1 to 12 do
     begin
          a[x]:=random(41)*(random(10)/5)-10;
          writeln('a[',x,']:',a[x]);
          if a[x]<0 then p:=p*a[x];
     end;
     writeln;
     writeln(p:6:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?