В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
iavorskayavika
iavorskayavika
21.11.2021 01:18 •  Информатика

30 ! составьте программу ,которая формирует массив ,содержащий 8 случайных целых чисел, принадлежащих промежутку [0; 5] ,и преобразует элементы массива по следующему правилу: чётное число умножает на 5 ,а от нечётного отнимает 2.

Ответ:
dashenkanosova5
dashenkanosova5
27.06.2020 01:44
Var
a:array[1..8] of integer;
i:integer;
begin
randomize;
for i:=1 to 8 do
begin 
a[i]:=random(6); 
  if a[i] mod 2 = 0 then a[i]:=a[i]*5
  else a[i]:=a[i]-2;
  write(a[i],' ');
 end;
end.

Надеюсь на "Лучший ответ"
0,0(0 оценок)
Ответ:
Машkа
Машkа
27.06.2020 01:44
Uses crt;
var a:array[1..8] of integer;
    x:integer;
begin
     randomize;
     for x:=1 to 8 do
     begin
          a[x]:=random(6);
          writeln('a[',x,']:',a[x]);
     end;
     writeln;
     for x:=1 to 8 do
     begin
          if a[x] mod 2=0 then a[x]:=a[x]*5
             else a[x]:=a[x]-2;
          writeln('a[',x,']:',a[x]);
     end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?