Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
poladasadov
19.08.2021 22:28 •
Информатика
Написать программу в c++ дан одномерный массив x из n элементов. найти порядковый номер первого по счёту положительного элемента с чётным порядковым номером. все отрицательные элементы после него переписать в массив y.
Ответ:
MDI1
27.06.2020 01:43
#include
#include
#include
#include
int odd(int i)
{
return 2 * i + 1;
}
int square(int i)
{
return i * i;
}
typedef boost::counting_iterator counter;
typedef boost::transform_iterator transformer;
transformer odds(int n)
{
return transformer(counter(n), odd);
}
transformer squares(int n)
{
return transformer(counter(n), square);
}
int main()
{
using namespace std;
cout << "Enter vector length: ";
int n; cin >> n;
cout << inner_product( odds(0), odds(n), squares(0), 0 ) << endl;
0,0
(0 оценок)
Популярные вопросы: Информатика
AnNik08
27.12.2021 15:48
Вэлектронной таблице значение формулы =срзнач(a1: c1) равно 5. чему равно значение ячейки d1, если значение формулы =сумм(a1: d1)равно 7? 1) 2 2) -8 3) 8 4) -3...
оаилпаидшп
30.04.2022 20:00
N = 64 символI- 1,5 байтK-?...
kuzmichkinvale
25.03.2020 03:21
Известный армянский шахматист Ашот Наданян сказал об академической честности следующее: «У плагиатора две музы: одну зовут Сору, другую - Paste.» Данное предложение закодировано...
SekretKtoYa
13.09.2022 14:06
Информационный объем предложения, закодированного в ASCII, составляет 64 бита. Определи информационный объем данного предложения, если пользователь перекодирует его в...
dasa2208
04.02.2022 07:45
Решить все примеры на двоичную систему счисления.9 17 245 451 596...
Катя18471
23.04.2020 06:25
Виртуалды машина түрлерің жаз. Көмектесіңдерш өтініш ...
Totiva
29.12.2020 08:34
Задание 1. В каждом определении выберите и подчеркните подходящий вариант из предложенных: Пример: Память — устройство, предназначенное для хранения/удаления информации....
abukaka
19.04.2021 22:32
Ақпараттың өлшем бірліктері. 2-сабақ 5 ТБ есептеу үшін дұрыс формуланы таңдашембақ5 - 8 бит5 - 1024 - 8 бит5 - 1024 - 1024 8 бит5 - 1024 - 1024 - 1024 8 бит5 - 1024 -...
НюшаS12
30.06.2022 15:59
Какую пункт контекстного меню надо выбрать для создания папки а) new. b) folder...
sirozazuruhin
04.11.2022 09:32
Сколько будет 11 mod 5 (почему-то пишут 1, а я всё равно не понимаю, т. к если 11 mod 5 у меня получается 2,2 тоесть объясните какой ответ правильный и почему ....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include
#include
#include
int odd(int i)
{
return 2 * i + 1;
}
int square(int i)
{
return i * i;
}
typedef boost::counting_iterator counter;
typedef boost::transform_iterator transformer;
transformer odds(int n)
{
return transformer(counter(n), odd);
}
transformer squares(int n)
{
return transformer(counter(n), square);
}
int main()
{
using namespace std;
cout << "Enter vector length: ";
int n; cin >> n;
cout << inner_product( odds(0), odds(n), squares(0), 0 ) << endl;