В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sernikovs
sernikovs
19.04.2020 04:14 •  Информатика

Дан целочисленный массив из 30-ти элементов.написать программу,которая позволит найти среднее арифметическое положительных элементов массива .

Ответ:
muratov20011
muratov20011
27.06.2020 01:33
Паскаль:

var mas : array[1..30] of longint;
n,i : longint;
r : real;
begin
 for i:=1 to 30 do read (mas[i]);
 n:=30; r:=0;
 for i:=1 to 30 do begin
  if mas[i]<1 then begin mas[i]:=0; n:=n-1;
  r:=r+mas[i];
 end;
 writeln(r/n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?