В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
погипж
погипж
20.06.2020 14:33 •  Информатика

задачка по информатике. Операторы циклов Написать программу для вычисления заданного выражения и вывода на экран полученного значения, используя заданный циклический оператор.
Выражение: 0,8 - 0,10 + 0,12 -...- 0,26
оператор цикла: while

Ответ:
Yaroslav1RUS
Yaroslav1RUS
13.02.2022 11:50

numb = 8

step = 2

pred = 26

da = float('0.'+str(numb))

opr = False

while numb < pred:

   numb += step

   if opr:

       da += float('0.'+str(numb))

   else:

       da -= float('0.'+str(numb))

   opr = not opr

print(round(da,5))

Если есть вопросы - пиши

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?