В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
semak03
semak03
12.11.2020 20:53 •  Информатика

Написать программу (в pascal) и составить блок-схему по : в двумерном массиве произвольной размеренности подсчитать количество элементов, равных наибольшему элементу в этом массиве. вывести значение наибольшего элемента.

Ответ:
адекс3
адекс3
26.06.2020 21:02
Алгоритм
Ввод массива A[n,m]
Max := A[1,1]; k := 1; p := 1; s := 0;
Алгоритм
Ввод массива A[n,m]
Max := A[1,1]; k := 1; p := 1; c := 0;
Цикл по i от 1 до n (по строкам)
Цикл по j от 1 до m (по столбцам)
Если (A(i, j) = Max) and ((i<>k) or (j<>p)) То c := c+1;
Если (A(i, j) > Max) То
k := i; p := j; c := 1;
Max: = A(i, j);
Конец Если
Конец цикла по столбцам
Конец цикла по строкам
Вывод "Элемент ", Max, " встречается ", c, " раз"
Конец.

Программа
var A: array of array of integer
var i,j,m,n,k,p,s,Max: integer
BEGIN
uses crt; clrscr;
write ('Vvedite kol-vo strok: '); readln (n);
write ('Vvedite kol-vo stolbtsov: '); readln (m);
setlength(A,n,m);
for i=1 to n do
begin
for j=1 to m do
begin
write ('Vvedite element vassiva: '); readln (A[i,j]);
end;
end;
Max := A[1,1]; k := 1; p := 1; c := 0;
for i=1 to n do
begin
for j=1 to m do
begin
if (A(i, j) = Max) and ((i<>k) or (j<>p)) then c := c+1;
if (A(i, j) > Max) then
begin
k := i; p := j; c := 1;
Max: = A(i, j);
end;
end;
end;
write ('Element ', Max, ' vstrechaetsya ', c, ' raz');
END.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?