В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
searchsignal
searchsignal
27.08.2022 12:06 •  Информатика

Программа получает на вход целые числа, количество введённых
чисел неизвестно, последовательность чисел заканчивается числом
0 (0 – признак окончания ввода, не является членом
последовательности). Количество чисел не превышает 1000.
Введённые числа не превышают 30 000. Гарантируется, что в
последовательности есть хотя бы одно число, кратное трём.
Программа должна вывести наименьшее число, кратное трём.

Ответ:
annamoz2004
annamoz2004
05.02.2022 22:20

#include<iostream>

using namespace std;

int main(){

   int temp,min,flag;

   while(cin>>temp){

       if (!(flag) && temp%3==0){

           min=temp;

           flag++;

      }

      if(temp%3==0 && temp<min){

           min=temp;

       }

   }

   cout<<min;

}

как-то так.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?