В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dankytop
Dankytop
19.12.2021 17:00 •  Информатика

Спрограммой в паскале, дан массив из n чисел. определить количество чисел, превышающих число 5. найти сумму этих чисел. напишите программу.. (одномерный массив)

Ответ:
Яник111111111
Яник111111111
26.06.2020 16:53
Program arr;
var 
 ar : array[1..100] of Integer; 
 i, size, count, sum : Integer;
begin 
 Writeln('Введите размер массива');
 Readln(size); 
 if (size > 100) then begin 
  Writeln('Hазмер массива превышает 100 элементов. Программа будет завершена...');   
 Readln; 
 end 
 else begin 
  Writeln('Введите ', size, ' чисел');   
 for i:=1 to size do begin     
 readln(ar[i]);     
 if ar[i] > 5 then begin       
 Inc(count);       
 Inc(sum, ar[i]);     
 end;   
 end;   
 Writeln('Вы ввели ', i - 1, ' чисел из которых ', count, ' больше 5, а их сумма составляет ', sum);   
 Readln; 
 end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?