В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ulpashkova
ulpashkova
26.02.2020 09:32 •  Информатика

Дан массив а, состоящий из 6 элементов. вывести элементы массива. изменить порядок следования элементов массива на обратный, вывести инвертированный массив. , , составить программу в ! вот, например, я начала. program z10; var p, i: integer; x: array [1..6] of integer; begin for i: =1 to 6 do begin p: =a[i]; а как дальше поменять местами остальные элементы? ?

Ответ:
raddycat
raddycat
26.06.2020 16:02
1)
просто выводим элементы наооборот
program gt;
var a:array[1..6]of longint;
n,i:integer;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
end;
for i:=6 downto 1 do
begin
write(a[i],' ');
end;
end.
2)
добавляем дополнительный массив b
program gt;
var a,b:array[1..6]of longint;
n,k,i:integer;
begin
read(n);
k:=7;
for i:=1 to n do
begin
read(a[i]);
k:=k-1;
b[k]:=a[i];
end;
for i:=1 to 6 do
begin
write(b[i],' ');
end;
end.
3)
Изменяем элементы массива без дополнительных элементов
Program z10;
VAR 
p, i: Integer; 
x: Array [1..6] of integer;
Begin
For i:=1 to 3 Do 
begin
p:=a[i];
a[i]:=a[6-i+1];
a[6-i+1]:=p;
end;
for i:=1 to 6 do
begin
write(a[i],' ');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?