В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
кура000
кура000
14.05.2020 11:09 •  Информатика

Строки в стиле С •Написать программу, которая вводит символьный массив из 15-ти или
меньшего числа элементов и находит в нем символ с наименьшим ASCII-кодом

Ответ:
shvbur75
shvbur75
31.01.2022 01:00

#include <stdio.h>

#include <windows.h>

#include <string.h>

#define _MAX_STRING_SIZE_ 15

int main()

{  

   SetConsoleCP(65001);

   

   char str [_MAX_STRING_SIZE_];

   scanf("%s", &str);

   int min = (int)str[0];

   for(int i = 0; i < strlen(str); i++)

       if((int)str[i] < min)

           min = (int)str[i];

   printf("%d", min);

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?