В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Marfaaax1338
Marfaaax1338
04.02.2023 17:58 •  Информатика

Дан массив c(m). найти отношение максимального к минимальному элементу. написать программу в pascal,

Ответ:
DoKim01
DoKim01
26.06.2020 12:49

const m=10;

var c:array[1..m] of integer;

max,min,i,j: integer;

begin

writeln('Массив:');

for i:=1 to m do

begin

c[i]:=random(50);

write(c[i],' ');

end;

writeln;

max:=c[1];

min:=c[1];

for i:=2 to m do

begin

if c[i]>max then max:=c[i];

if c[i]<min then min:=c[i];

end;

writeln('max = ',max,' min = ',min,' max/min = ',max/min:5:2);

end.

Пример:

Массив:

27 29 35 42 30 42 27 42 21 31  

max = 42 min = 21 max/min =  2.00

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?