В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
valeriatomilov
valeriatomilov
27.11.2021 13:03 •  Информатика

Напишите в питоне , Алгоритм вычисления значения функции
F(n), где n – натуральное число,
задан следующими соотношениями:
F(n) = 1 при n = 1;
F(n) = n +F(n − 1), если n чётно,
F(n) = 2 * F(n − 2), если n > 1 и при этом n нечётно.
Чему равно значение функции
F(26)?

Ответ:
vNeronRazerv
vNeronRazerv
19.01.2022 16:40

4122

Объяснение:

def F(n):

   if n == 1:

       return 1

   elif n % 2 == 0:

       return n + F(n - 1)

   else:

       return 2 * F(n - 2)

print(F(26))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?