В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
AlexSchoolLife
AlexSchoolLife
30.09.2021 18:33 •  Информатика

1. Составьте программу, которая находит среднее арифметическое всех чисел от 5 до 27.


1. Составьте программу, которая находит среднее арифметическое всех чисел от 5 до 27.

Ответ:
Chehows
Chehows
18.01.2022 06:00

summa = 0

kolvo = 0

for i in range (5, 28):

   summa += i

   kolvo += 1

print(summa/kolvo)

Объяснение:

для начала задаём два "счётчика" - сумма и количество

для каждого числа (назовём его i) в диапазоне от 5 до 28 (28, а не 27, потому что программа считает не включительно:

к сумме добавляем это число

к количеству чисел добавляем 1

\\значок "+=" работает так: a+=1 обозначает то же самое, что и a = a+1\\

таким образом к концу этого цикла мы получим общую сумму всех чисел и их количество

программа выведет результат от деления суммы на количество

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?