В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Sofa29122005
Sofa29122005
27.07.2022 04:42 •  Информатика

Составить программу: 1. задано пятизначное число. выделить цифры, стоящие в разряде единиц и разряде тысяч. вывести их в порядке убывания 2. задано четырехзначное число. удалить из записи числа последнюю цифру. определить, будет ли оставшееся число кратно 11

Ответ:
ыооп
ыооп
01.10.2020 13:42
1.
uses crt;
var x:integer;
begin
read(x);
if inttostr(x)[1]>inttostr(x)[5] then
writeln(inttostr(x)[1],' ',inttostr(x)[5])
else 
writeln(inttostr(x)[5],' ',inttostr(x)[1]);
end.
2.
uses crt;
var x:integer;
begin
read(x);
if (x div 10) mod 11=0 then
writeln('Yes')
else
writeln('No');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?