В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
evstifeevod
evstifeevod
04.09.2022 20:49 •  Информатика

Нужно написать программу на python используя цикл while. (Задача обозначена красным цветом).


Нужно написать программу на python используя цикл while. (Задача обозначена красным цветом).

Ответ:
лоллрр
лоллрр
16.01.2022 22:40

ok = True

prev = int(input())

cur = prev

while True:

   cur = int(input())

   if cur == 0:

       break

   if (cur > 0 and prev > 0) or (cur < 0 and prev < 0):

       ok = False

   prev = cur

if ok:

   print("YES")

else:

   print("NO")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?