В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
polsedegova
polsedegova
02.07.2021 05:26 •  Информатика

1cоставить программу,которая позволяет ввести строку s,затем после каждой буквы "а" вставить пробел. 2 составить программу,которая удаляет в строке s все буквы "о"

Ответ:
rrrl1
rrrl1
26.06.2020 11:09
На всякий случай сделал проверку и на русские, и на английские.
задача 1.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='a') or (s[i]='а') then
s:=copy(s,1,i)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
задача 2.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='о') or (s[i]='o') then
s:=copy(s,1,i-1)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?