В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vika2075
vika2075
13.12.2022 13:42 •  Информатика

Составить программу (в pascal) позволяющую найти минимальный элемент массива. подсчитать количество элементов в массиве, равных минимальному. размеренность массива произвольная.

Ответ:
polinaandreeva10
polinaandreeva10
26.06.2020 11:00
Program my;
var  k,i,z:integer; 
     a:array[1...N]:integer; 
begin
k:=99999;
for i:=1 to N do                   
 if a[i]<k then k:=a[i];
z:=0;
for i:=1 to N do 
 if a[i]=k then z:=z+1;
end.
=)  
0,0(0 оценок)
Ответ:
Машkа
Машkа
26.06.2020 11:00
Uses crt;
const N=10;
var a:array [1..N] of integer;
     x,min,k:integer;
begin
for x:=1 to N do
begin
write('a[',x,']:',a[x]);
readln(a[x]);
end;
min:=a[1];
for x:=1 to N do
if a[x]<min then min:=a[x];
for x:=1 to N do
if a[x]=min then inc(k);
writeln('Минимальный элемент: ',min,'. Таких элементов в массиве: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?