В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
HKL11
HKL11
29.12.2020 06:42 •  Информатика

Напишите программу на Python, которая в последовательности целых чисел находит два разных по значению наибольших числа среди чисел не кратных трем


Напишите программу на Python, которая в последовательности целых чисел находит два разных по значени

Ответ:
ЗдаровАаА
ЗдаровАаА
12.01.2022 11:00

Программа:

num = int(input("Введите число: "))

data_num = []

while num != 0:

   if num % 3 != 0:

       data_num += [num]

   num = int(input("Введите число: "))

num_max = max(data_num)

print("\nПервое максимальное число:", num_max)

data_num = [el for el in data_num if el != num_max]

print("Второе максимальное число:", max(data_num))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?