В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ivanovasvetak
ivanovasvetak
02.03.2021 12:00 •  Информатика

Напишите программу поиска всех двузначных чисел, в которых есть цифра n или само число делится на n.

Ответ:
qwerty2021
qwerty2021
26.06.2020 10:16
Uses crt;
var a,n:integer;
begin
     write('n:'); readln(n);
     if n>=10 then writeln('error')
     else
     for a:=10 to 99 do
     if (a mod n=0) or (a div 10=n) or (a mod 10=n) then writeln(a);
end.
0,0(0 оценок)
Ответ:
garachuk75
garachuk75
26.06.2020 10:16
 Dim i As Integer
        Dim msg As String   
    Dim n As Integer 

       n = CInt(InputBox("Введите n")) 

       For i = 10 To 99 
          If CStr(i).IndexOf(n) > -1 Or i Mod n = 0 Then
                msg = msg & i & vbCrLf 
          End If   
     Next       
 MsgBox(msg)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?