В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
viktoriacotik1
viktoriacotik1
02.11.2020 13:16 •  Информатика

Напишите программу на языке паскаль для нахождение количества цифр в записи положительного целого числа x.

Ответ:
умник202323
умник202323
01.10.2020 13:42
Program ololo;
var a,b:integer;
begin
read(a);
if a = 0 then begin write(1); exit; end;
while a <> 0 do
begin
  inc(b);
  a := a div 10;
end;
write(b);
end.
0,0(0 оценок)
Ответ:
максик88
максик88
01.10.2020 13:42
Вот так гораздо проще.

var s:string;
begin
readln(s);
writeln(length(s));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?