В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
0blako
0blako
02.02.2023 15:50 •  Информатика

Написать программу на с++ . найти сумму элементов последовательности b1, , b15 , расположенных правее последнего отрицательного элемента и номер этого элемента.

Ответ:
dianka2712
dianka2712
26.06.2020 07:51
#include <iostream>

using namespace std;

int main()
{
    int a[15];
    int i = 0;
    int sum = 0;
    for (; i < 15; i++)
        cin >> a[i];
    for (i = 14; (i != 0) && (a[i]>0); i--) 
        sum += a[i];   
    cout << "i = " << i+1 << endl;
    cout << "summa = " << sum << endl;
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?