В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Vadya91102
Vadya91102
09.05.2023 01:48 •  Информатика

Написать программу Pascal. Найти простые числа х и у, которые в произведении дают число z, типа longint.

Ответ:
sapesalex
sapesalex
23.12.2021 06:00

число Z вводится

Pascal

var

 i, z: longint;

begin

 write('Введите Z : ');

 readln(z);

 for i:=1 to trunc(sqrt(z)) do begin

   if z mod i = 0 then

     writeln(i, ' * ', z/i);

 end;  

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?