В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу к задаче: "Найти произведение элементов целочисленного, одномерного массива с четными номерами, состоящего из n элементов. Элементы вводятся с клавиатуры." Паскаль.

Ответ:
denisst105
denisst105
20.12.2021 08:50

Типовые задачи на Паскале (массивы)

Массив- это упорядоченный набор однотипных элементов, обозначаемых одним именем; доступ к элементу массива осуществляется по его номеру.

Для записи элементов массива в память компьютера нужно выделить для их хранения необходимое количество ячеек памяти, которое определяется размером массива.

В программе для каждого массива должны быть указаны его параметры: имя, размерность и размер. Бывают одномерные, двумерные и т.д. массивы. Это называется размерностью.

Одномерные массивы (последовательности).

A: 3,-4,0,3,-5,10,0

A[1]=3, A[3]=0, A[7]=0

I - номер элемента, A[I] - элемент массива, стоящий на I-ом месте

1. Сформировать и вывести на экран последовательность из n элементов, заданных датчиком случайных чисел на интервале [-23, 34].

Var a: array[1..100] of integer;

i, n: integer;

Begin

Write (‘Сколько элементов? ’); Readln (n);

For i=1 to n do

begin

a[i]:= Random(58)-23;

writeln (a[i],’ ‘);

end;

End.

Var a: array[1..100] of integer;

i, n, p: integer;

Begin

Write (‘Сколько элементов? ’); Readln (n);

p:=1;

For i:=1 to n do

begin

write (‘введите число’); readln (a[i]);

p:=p*a[i];

end;

writeln(‘произведение элементов равно: ‘,p);

End.

Var a: array[1..100] of real;

i, n: integer;

s: real;

Begin

Write (‘n=’); Readln (n);

s:=0;

For i:=1 to n do

begi

write (‘введите число’); readln (a[i]);

s:=s+a[i];

end;

writeln(‘сумма элементов равна ‘,s);

End.

Var a: array[1..100] of real;

i, n: integer;

s,sred: real;

Begin

Write (‘n=’); Readln (n);

s:=0;

For i:=1 to n do

begin

write (‘введите число’); readln (a[i]);

s:=s+a[i]

end;

sred:=s/n;

writeln(‘среднее арифметическое элементов: ‘,s);

End.

Program sumshet;

Var a: array[1..100] of real;

i, n: integer;

s,sred: real;

Begin

Write (‘n=’); Readln (n);

s:=0;

For i:=1 to n do

begin

write (‘введите число’); readln (a[i]);

if i mod 2 = 0 then s:=s+a[i];

end

Var a: array[1..100] of integer;

i, n, p: integer;

Begin

Write (‘Сколько элементов? ’); Readln (n);

P:=1;

For i=1 to n do

begin

a[i]:= Random(46)-19;

writeln (a[i],’ ‘);

if i mod 2 <> 0 then P=P*a[i];

end;

Writeln(‘Произведение элементов с нечетными номерами:’, P);

Var a: array[1..100] of integer;

i, n, p, t: integer;

Begin

Write (‘Сколько элементов? ’); Readln (n);

P:=1;

For i=1 to n do

begin

a[i]:= Random(104)-56; writeln (a[i],’ ‘);

if (i mod 2 = 0) and (a[i]>t) then P=P*a[i];

end;

Writeln(‘Произведение элементов с четными номерами, превосходящие число t:’, P);

РЕКЛАМА

End.

Var a: array[1..100] of real;

i, n: integer;

min: real;

Begin

Write (‘n=’); Readln (n);

For i:=1 to n do

begin

write(‘a[‘,i,’]=’); readln (a[i]);

end;

min:=a[1];

For i:=2 to n do

If a[i]< min then min:=a[i];

Program numberminim;

Var a: array[1..100] of integer;

i, n, num, min: integer;

Begin

Write (‘n=’); Readln (n);

For i:=1 to n do

begin

a[i]:= Random(46)-20;

writeln (a[i]);

end;

min:=a[1];

num:=1;

For i:=2 to n do

If a[i]< min then

begin

min:=a[i];

num:=i;

end;

Writeln(‘ номер наименьшего элемента: ‘,num);

End.

Program kolv0;

Var a: array[1..100] of integer;

i, n, k: integer;

Begin

Write (‘n=’); Readln (n);

For i:=1 to n do

begin

Write(‘a[‘,i,’]=’); readln (a[i]);

if a[i]=0 then k:=k+1;

end

Var a: array[1..100] of integer;

i, n, k: integer;

Begin

Write (‘n=’); Readln (n);

For i:=1 to n do

begin

Write(‘a[‘,i,’]=’); readln (a[i]);

if a[i] mod 2=0 then k:=k+1;

end;

Writeln(‘количество четных элементов: ’, k);

end.

Var a: array[1..10] of real;

i, k: integer;

C, S, sred: real;

Begin

For i:=1 to 10 do

begin

write(‘a[‘,i,’]=’); readln (a[i]);

end;

write(‘введите С: ‘); readln (C );

For i:=1 to 10 do

begin

If a[i]>C then

begin S=S+a[i]; K=K+1; end;

end;

sred=S/k;

Writeln(‘среднее арифметическое чисел, превосходящих ‘,C,’ равно ‘,sred)

Var a: array [1..100] of integer;

i, n, p: integer;

Begin

p:=1;

write ('n='); readln (n);

for i:=1 to n do

begin

write ('a[',i,']='); readln (a[i]);

if i mod 2=0 then p:=p*a[i];

end;

Writeln ('произведение элементов массива с четными номерами равно ',p);

End

*Вроде правильно*

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?