В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
meshiydima
meshiydima
06.03.2022 21:25 •  Информатика

Python: 1.Напишите программу, которая получает с клавиатуры числа до тех пор, пока не будет введено число 0. В конце работы программы на экран выводится среднее арифметическое введённых чисел(не считая 0) 2.Напишите программу, которая получает с клавиатуры натуральное число N и определяет сумму всех его делителей, меньших самого числа. Например, для числа 8 эта сумма равна 1+2+4=7.

Ответ:
MaxTwAiNer12
MaxTwAiNer12
19.12.2021 20:50

# Задание 1

sumOfElements = 0

numberOfElements = 0

currentNumber = int(input())

while currentNumber != 0:

   sumOfElements += currentNumber

   numberOfElements += 1

   currentNumber = int(input())

if sumOfElements != 0:

   res = sumOfElements / numberOfElements

   res = round(res, 1)

print(res)

# Задание 2

arr = []  # array for divisors

number = int(input())

for i in range(1, number):

   if number % i == 0:

       arr.append(i)

print(sum(arr))

детский вариант:

# Задание 1

res = 0

summ = 0

n = 0

a = int(input())

while a != 0:

   summ = summ + a

   n = n + 1

   a = int(input())

if summ != 0:

   res = summ / n

   res = round(res, 1)

print(res)

# Задача 2

summ = 0

n = int(input())

for i in range(1, n):

   if n % i == 0:

       summ = summ + i

print(summ)

0,0(0 оценок)
Ответ:
robiya86
robiya86
19.12.2021 20:50

Программа:

Python:

№1 - вариант 1)

arr = []

element = float(input())

while element != 0:

   arr.append(element)

   element = float(input())

print(sum(arr)/len(arr))

№1 - вариант 2)

element = float(input())

elementSumm = elementCount = 0

while element != 0:

   elementCount += 1

   elementSumm += element

   element = float(input())

print(elementSumm/elementCount)

№2)

N = int(input())

summ = 0

for i in range(1, N):

   if N % i == 0:  summ += i

print(summ)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?