В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Python с цикла while! Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 5.

Ответ:
katesgo
katesgo
17.12.2021 16:10

n = int(input())

maxc = -100000000

while n > 0:

   a = int(input())

   if a % 5 == 0:

       maxc = max(maxc,a)

   n -= 1

print(maxc)

0,0(0 оценок)
Ответ:
Nikitos1111111111111
Nikitos1111111111111
17.12.2021 16:10

x = int(input())

a = 0

z = 0

lel = ':)'

while a < x:

   a += 1

   f = int(input())

   if f%5:

       if lel == ':)':

           lel = f

       else:

           lel = max(lel,f)

print(lel)

Если есть вопросы, пиши

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?